PowerFlow Forex Expert Advisor

MetaTrader Build 418 Bug Alarm: How to Switch back to the Previous Build Version!

By Alexander
In Forex Basics
Mar 27th, 2012
33 Comments
10190 Views

A couple of days ago, Meta Quotes released build 418 of the Meta Trader 4 terminal. The problem is that the build includes a serous bug and as the result most expert advisors stopped working.

Forums are flooded with “What should I do? My expert advisors stopped working!” threads and e-mail inboxes of developers are full of complains from clients.

The good news is that Meta Quotes already knows about the bug. Stanislav Starikov from the Meta Trader support team told me that they would fix the bug and release a new build version within one week.

Here’s what you can do in the meantime:

First of all, you should check, which build version is installed on your PC. To do so, open your terminal, go to “Help” and click where stands “About.” A new window will popup where you can see what build version you have installed.

How to downgrade Metatrader 4 build 418 to previous version

How to return previous version of MT4

If you didn’t update to build 418

In this case, you are lucky. When you start your terminal and the update window will popup, simple close it or disable live updates completely.

If you already installed MT4 build 418

In this case, you will need to switch back (downgrade) to the previous build. It’s easy, takes only a couple of minutes.

1. Close the terminal and open the folder where the terminal is installed. The folder is usually located in C:\Program Files.

MT4 build 418

2. Download the previous version of the executable file and extract the file terminal.exe from the archive.

3. Replace it with the terminal.exe file in your folder.

MT4 build 418 issue

That’s it. You can now start your terminal and continue to use your expert advisors.

Note: The terminal.exe file from the archive belongs to FXCC, but it’s compatible with all brokers. The .exe file is the same for all brokers, only the configuration files are different.

As many fellow traders have troubles with the actual build, please do me and the forex community a favor and spread the word about this post.

Happy Trading!

Alexander

PS: Comments are welcome too!

VN:F [1.9.22_1171]
Rating: 5.0/5 (2 votes cast)
MetaTrader Build 418 Bug Alarm: How to Switch back to the Previous Build Version! , 5.0 out of 5 based on 2 ratings

33 Responses to “MetaTrader Build 418 Bug Alarm: How to Switch back to the Previous Build Version!”

  1. Norman Ebbs says:

    Excellent thanks

  2. Tony says:

    Thank you Alexander!
    All robots back to work :)

  3. Cristina Diaz says:

    Excellent, thank you very much Alexander

  4. Johnny Honda says:

    Hello
    I have a problem: I want to use build 228 (or any version before 400). I can install it, but I can’t connect with that build to my brokers??

  5. Josh says:

    I haven’t gotten yet the build 418 and still using the “225″ from Forexpro. Yet the live update window keeps popping up every 5 seconds right after I close it and I can’t get any further. Any idea on what to do here

    At the bottom right, it shows “Old version”

    • Alexander says:

      Hello Josh, “Old Version” message indicates that the build is no longer supported by your broker. You will need to install a later version. To get rid of the annoying update reminder you can disable live updates.

  6. Mischa says:

    Wow, finally a developer who is more than a marketer. Thank you for writing this great article. I look forward to buying some robots from you soon.

  7. Sergio says:

    Thank you !!

  8. LogicaLucidity says:

    Here is my post from 03-23-2012 on JTAToday. This and the posts that follow provided many versions… 416 and down. This includes the 409 terminal.exe that I uploaded to mediafire.
    http://www.jtatoday.info/forum/showthread.php?tid=3844&pid=18745#pid18745
    Miro has provided you with my media fire link above.
    LL

  9. Alexander says:

    Thank’s! Nice article and great forum.

  10. brian says:

    Do we know if this is still on schedule:
    “The good news is that Meta Quotes already knows about the bug. Stanislav Starikov from the Meta Trader support team told me that they would fix the bug and release a new build version within one week.”
    Will this be a new bulid number?

  11. brian says:

    update build 419 arrived for axitrader but not for gomarkets!!!
    I assume 419 fixes the bug?
    I haven’t received any notice.

    • Alexander says:

      Dear Brian,

      I have checked MT4 build 419 and haven’t found any problems.
      Feel free to use your Expert Advisors after latest update to 419th build.

  12. KhooEdward says:

    Is the current build 419 corrected this problem already?

  13. Jim says:

    I have two MT4 terminals that aren’t updating to 419. One is a 406 and the other is a 401. Both crash at the “terminal.exe” during Live Update. My operating system is a Vista. Any suggestions, chaps? I’ld rather update than do a fresh download. Thanks.

    • Alexander says:

      Hello Jim,

      The process of updating is the same as downgrading. Just replace terminal.exe as I described in article. If you want to have MT4 build 416 – use terminal.exe file from this article.

  14. Trajectory7 says:

    Hello Alex,

    Thanks for the help you’ve given.

    I’ve downloaded the terminal.exe for Build 409 an replaced the older version (which was also Build 409), just to see if MT4 would stay running. However, MT4 does the same thing – it launches, but it then attempts to run liveupdate. When simply close the liveupdate windows, MT4 Build 409 shuts itself down without warning.

    I two different install paths: one path for the live account, and one path for the demo/test account. I need MT4 Build 409, because I use a script (a few .dlls) that feed tick data to the Tester Engine, and that allow me to do multi-time frame back-testing in MT4. But, that set-up cannot run anything above Build 409.

    Any idea why my Build 409 won’t simply allow the closing of the liveupdate window? I’ve tried renaming liveupdate to liveupdate.old, but then MT4 launches and immediately shuts down without warning.

    I can simply disconnect the network connection and then launch MT4. That gives me back the Back Tester, but it also does not allow any live forward testing, as once MT4 detects a network connection, it will once again attempt to run liveupdate, and the whole cycles starts over again.

    Any additional help is appreciated!

    Thanks, again.
    T7

    • Alexander says:

      Hello T7,

      I used to rename LiveUpdate.exe to “LiveUpdate.exe-”. It works fine for me, try to rename file to precisely LiveUpdate.exe-.
      In case your platform still crashes, try to reinstall it and downgrade to 409 once again and repeat renaming LiveUpdate.exe.

      Some brokers use UpdatePlatform.exe for updating, which is situated in C:\Program Files\your MT folder\config. To avoid updates, rename the file to UpdatePlatform.exe-

  15. Trajectory7 says:

    Hello Alex,

    It turns out that any iCustom Indicator that get loaded to a chart, will cause MT4 crash without warning or error message, in build 409.

    This behavior is all of a sudden. I ran these same iCustom Indicator files in the exact same unchanged MT4 installation path for a while now, without any problems at all. All of a sudden, yesterday, while browsing the web, I came back to MT4 to do some research. That’s when MT4 build 409 simply crashed. Today, after having gone through the re-install, liveupdate decommission (I have no UpdatePlatform.exe) and recompile of all iCustom indicators, I get the same exact problem.

    If I launch MT4 build 4 without any iCustoms loaded to any chart, then MT4 runs just fine. The moment I load an iCustom to any chart, it crashes. I have another MT4 Build 419 that runs with these same exact iCustom indicators and there are no problems at all. That MT4 version just updated itself and it still runs all iCustoms.

    These iCustoms were created under MT4 Build 409, so they should run there without issues, but all of a sudden, iCustoms that used to run perfectly fine under 409, now crash 409. That makes no sense at all. I changed absolutely nothing between yesterday (when they were working just fine) and the point at which MT4 build 409 crashed.

    Ever heard of this kind of problem with iCustom Indicators before?

    Thanks.
    T7

  16. Neeraj says:

    Hi
    I tried to install fx-pulse-1.0.3-beta mt4 but it shows the error “There is a problem with this Installer package.A program run as part of the setup did not finish as expected.Contact your support personnel or package vendor.” Pls help me

  17. ElmoDeMoraes says:

    Thank you so much.

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>

facebook comments: